Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 08, 2026 - 06:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 23, 2026 - 18:27 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 21, 2026 - 21:13 UTC
Scheduled
MAINTENANCE INFORMATION ======================= Click Field Service Edge release Fuji MR23 to Production Environment listed below:
TARGET INSTANCES: ============== NA Production (PR01, PR03)
TARGET SERVICES: ============= All Product Services
AVAILABILITY: ========== All services will be available during this maintenance window.
PLANNED DATE: ============ Sunday, February 01, 2026
PLANNED START & END TIMES: ======================= NA-PR01: 06:30 AM to 10:00 AM UTC NA-PR03: 07:00 AM to 10:30 AM UTC
How can I get more information? ======================= Join our *Field Service Edge Release Announcement* group by clicking the link below to follow updates throughout the release cycle for FSE:
What is next? =========== * February 1-2 - Fuji MR23 Feature Activation in Production - NA Region
Thank You, Click Support
Posted Jan 13, 2026 - 08:43 UTC
This scheduled maintenance affected: North America - PR01 (Schedule, Integration, Mobile, Analytics, CEM) and North America - PR03 (Schedule, Integration, Mobile, Analytics, CEM).