Resolved
Dear ClickSoftware Customer,
We would like to inform you that the login URL login.clicksoftware.com is now depreciated. Going forward, all customers are requested to log in via our updated and more secure portal: click.okta.com (Please bookmark the link for future use).
Once logged in, please select the Click Community tile to access the community site.
This change is part of our ongoing efforts to enhance security and ensure a more seamless experience for our users.
If you have any questions or need assistance, please don’t hesitate to reach out to us or email cksw-support@salesforce.com.
Thank you for your continued support.
The ClickSoftware Team
Posted Apr 24, 2025 - 14:25 UTC
Investigating
We are currently experiencing an issue affecting access to login.clicksoftware.com, which may prevent users from logging in or accessing related services.
Our engineering team is actively investigating the root cause and working diligently to restore normal service as quickly as possible. We sincerely apologize for the inconvenience and appreciate your patience during this time.
We will continue to share updates here as more information becomes available.
Posted Apr 24, 2025 - 12:59 UTC
This incident affected: Click Customer Support (ClickAccess - Customer Community, Phone - Support Hotline), North America - PR01 (Schedule, Integration, Mobile, Analytics, CEM), North America - PR02 (Schedule, Integration, Mobile, Analytics), North America - PR03 (Schedule, Integration, Mobile, Analytics, CEM), North America - ST01 (Schedule, Integration, Mobile, Analytics, Remote Admin Tool), Canada - PR01 (Schedule, Integration, Mobile, Analytics, CEM), Canada - ST01 (Schedule, Integration, Mobile, Analytics, Remote Admin Tool), Europe - PR01 (Schedule, Integration, Mobile, Analytics, CEM, CEM), Europe - ST01 (Schedule, Integration, Mobile, Analytics, Remote Admin Tool, CEM), United Kingdom - PR01 (Schedule, Integration, Mobile, Analytics, CEM), United Kingdom - ST01 (Schedule, Integration, Mobile, Analytics, Remote Admin Tool), Australia - PR01 (Schedule, Integration, Mobile, Analytics, CEM, CEM), Australia - ST01 (Schedule, Integration, Mobile, Analytics, Remote Admin Tool), and Remote Admin Tool, CEM.