Incident Resolved
Incident Report for Click
Postmortem

Root Cause Analysis Report for this incident is available here:

RCA - March 20th, 2023 - FSE EU

This link requires login to ClickAccess Customer Community. Please email support@clicksoftware.com if you are an existing customer/partner of Click and require assistance accessing our customer community portal.

Posted Mar 30, 2023 - 21:00 UTC

Resolved
Dear Customer,

There was an issue affecting the Field Service Edge service which has now been resolved."

We are sorry for any inconvenience this may have caused. Ensuring your success is our top priority at Click, and we’re focused on learning from this issue and preventing any recurrences. We have started on the root cause analysis and it will be posted to this incident record once complete.

Thank you for your patience,

Click Support
Posted Mar 20, 2023 - 11:34 UTC
This incident affected: Europe - PR01 (Schedule).