Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 23, 2025 - 19:00 UTC
Scheduled
Dear Click Customer,
As part of our continuous efforts to enhance the performance of your Click Field Service Edge Cloud infrastructure, we will be upgrading our Redis Database Servers.
What is changing? ============= Redis Database Servers will be upgraded with an aim to improve performance and reliability of your FSE tenants.
When is this changing? ================ The infrastructure change is scheduled as below:
Planned time window: EU-PR: Aug 23th, 19:00–20:00 UTC
What to expect? ============ *Affected Service - Customer Engagement Module (CEM) may be unavailable or intermittently accessible for up to 30 minutes during the maintenance activity.
What actions do I need to take? ====================== * No specific actions are required from you * Please plan critical activities outside the window
Click takes the availability and security of our Cloud Services and its impact to your business seriously as we aim to achieve higher security standards for our infrastructure associated to your instance.
Should you have any questions, please contact our Customer Support by opening a case via our ClickAccess Customer community (https://community.clicksoftware.com/)
Best Regards, Click Support
Posted Aug 14, 2025 - 10:42 UTC
This scheduled maintenance affected: Europe - PR01 (CEM).