This link requires login to ClickAccess Customer Community. Please email support@clicksoftware.com if you are an existing customer/partner of Click and require assistance accessing our customer community portal.
Posted Nov 26, 2025 - 09:26 UTC
Resolved
Dear Customer,
The issue affecting the Field Service Edge service has now been resolved. All services are fully operational and working as expected.
We sincerely apologize for any inconvenience this may have caused, and we appreciate your patience throughout this process.
Best Regards, Click Software Support
Posted Nov 14, 2025 - 16:23 UTC
Investigating
Dear Customers,
We are currently investigating potential availability issues with our Field Service Edge (FSE) services. Our team is actively working on this, and we will keep you informed as soon as the issue is resolved.
We sincerely apologize for any inconvenience this may cause.
Best Regards, Click Software Support
Posted Nov 14, 2025 - 15:58 UTC
This incident affected: United Kingdom - PR01 (Schedule).