All Systems Operational

About This Site

We provide the current service availability for Click's cloud services.

Note: We have added an Analytics component under each FSE region. If you are not using Field Service Edge Analytics and do not wish to receive communications for this service you can click the 'subscribe to updates' button at the top to update your preferences.

Click here for a list of Incident History & Scheduled Maintenance: https://status.clicksoftware.com/history

North America - PR01 Operational
90 days ago
99.56 % uptime
Today
Schedule Operational
90 days ago
100.0 % uptime
Today
Integration Operational
90 days ago
98.69 % uptime
Today
Mobile Operational
90 days ago
100.0 % uptime
Today
Analytics ? Operational
North America - PR02 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
90 days ago
100.0 % uptime
Today
Integration Operational
90 days ago
100.0 % uptime
Today
Mobile Operational
90 days ago
100.0 % uptime
Today
Analytics ? Operational
North America - PR03 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
90 days ago
100.0 % uptime
Today
Integration Operational
90 days ago
100.0 % uptime
Today
Mobile Operational
90 days ago
100.0 % uptime
Today
Analytics ? Operational
North America - ST01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
Integration Operational
Mobile Operational
Analytics ? Operational
Remote Admin Tool Operational
90 days ago
100.0 % uptime
Today
Canada - PR01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
90 days ago
100.0 % uptime
Today
Integration Operational
90 days ago
100.0 % uptime
Today
Mobile Operational
90 days ago
100.0 % uptime
Today
Analytics ? Operational
Canada - ST01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
Integration Operational
Mobile Operational
Analytics ? Operational
Remote Admin Tool Operational
90 days ago
100.0 % uptime
Today
Europe - PR01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
90 days ago
100.0 % uptime
Today
Integration Operational
90 days ago
100.0 % uptime
Today
Mobile Operational
90 days ago
100.0 % uptime
Today
Analytics ? Operational
90 days ago
100.0 % uptime
Today
CEM Operational
90 days ago
100.0 % uptime
Today
Europe - ST01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
Integration Operational
Mobile Operational
Analytics ? Operational
Remote Admin Tool Operational
90 days ago
100.0 % uptime
Today
CEM Operational
90 days ago
100.0 % uptime
Today
United Kingdom - PR01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
90 days ago
100.0 % uptime
Today
Integration Operational
90 days ago
100.0 % uptime
Today
Mobile Operational
90 days ago
100.0 % uptime
Today
Analytics ? Operational
United Kingdom - ST01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
Integration Operational
Mobile Operational
Analytics ? Operational
Remote Admin Tool Operational
90 days ago
100.0 % uptime
Today
Australia - PR01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
90 days ago
100.0 % uptime
Today
Integration Operational
90 days ago
100.0 % uptime
Today
Mobile Operational
90 days ago
100.0 % uptime
Today
Analytics ? Operational
Australia - ST01 Operational
90 days ago
100.0 % uptime
Today
Schedule Operational
Integration Operational
Mobile Operational
Analytics ? Operational
Remote Admin Tool Operational
90 days ago
100.0 % uptime
Today
Click Customer Support Operational
90 days ago
100.0 % uptime
Today
ClickAccess - Customer Community Operational
90 days ago
100.0 % uptime
Today
Phone - Support Hotline Operational
Remote Admin Tool Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Scheduled Maintenance
Dear Customer,

We want to notify you of an update to the ClickMobile web for Field Service Edge on Chrome browsers planned for May 12th

Why was the update implemented?
=======================

As of May 29, Google is deprecating WebSQL on Chrome browsers and will provide no additional security updates for that version. A new local database is required to meet our commitment to Trust, which is our #1 value.
The update sets the browser to use the new local DB.

What is required from the users?
======================

All Chrome users must log out and log back into the ClickMobile web browser:

* Sandbox - After April 2nd.
* Production - After May 12th.

Chrome users who will not log out and log back in might not be able to store data or see any data information.

Important dates:
===========

* May 29th - Google releases the latest Chrome version that deprecates the old WebSQL DB. Any user with an older ClickMobile web version won’t be able to use ClickMobile web.


Thank You,
Click Support

Posted on Mar 28, 2024 - 06:53 UTC
FSE Fuji MR18 - Coming Release May 26, 2024 07:00-08:00 UTC
Dear Click Customer,

Click would like to update you on the upcoming Field Service Edge Fuji MR18 Release.

The Fuji MR18 release continues to focus on several improvements in product security and trust. Please visit our Planned Content for Next Release to find out more details of Fuji MR18:

https://community.clicksoftware.com/s/article/Planned-Content-for-Next-Release

*ClickAccess Community Login Required.

What’s next?
===============

Please see below the target maintenance schedule for both Sandbox and Production environments planned to be performed on your Click Field Service Edge instance. These dates may change based on testing results and feedback during sandbox deployment.

Sandbox Deployment:
=================

All Regions - Sunday, May 5, 2024

Production Deployment:
=================

EU & AU Regions - Sunday, May 19, 2024
NA, CA & UK Regions - Sunday, May 26, 2024

We will communicate with you 2 weeks prior to these maintenance activities with a POD specific post that contains up-to-date information along with their timelines.


Thank You,
Click Support

Posted on Mar 12, 2024 - 11:13 UTC
Dear Customer,

We would like to notify you of an update to the ClickMobile Touch app on iOS, which will be available for download in the Apple store as of May 28th. The new iOS app version is 20.5.12.

Why was the update implemented?
=======================

We have identified an SSO issue that causes the ClickMobile Touch logout action to fail due to Safari’s plugin update.

What is required from users?
====================

ClickMobile Touch iOS users should upgrade to the new app.

Important Dates:
============

* May 28th - The ClickMobile Touch app will be available in the Apple store.


Thank You,
Click Support

Posted on Apr 01, 2024 - 13:09 UTC
Dear Customer,

We would like to notify you of an upgrade to the Field Service Edge DB as follows:

UK Sandbox - April 7th
UK Production - June 9th

Why is the update implemented?
======================

As of July 9, 2024, Microsoft will no longer support MSSQL 2014 and will provide no additional security updates for that version. To meet our commitment to Trust, which is our #1 value, an upgrade to the MSSQL DB on all PODs is required.

How long will the upgrade take?
=====================

The upgrade process requires approximately one hour of downtime during the planned maintenance window.
If there’s a failure, the contingent plan to roll back and recover the DB should take about two hours.

What is required from users?
===================

No action is required from users as the Salesforce DBA team is responsible for the upgrade process.

Important dates:
===========

* April 7th - Sandbox POD will be upgraded to MSSQL DB 2019.
* June 9th - Production POD will be upgraded to MSSQL DB 2019
* July 9th - Microsoft no longer supports MSSQL 2014


Thank You,
Click Support

Posted on Mar 26, 2024 - 12:38 UTC
Past Incidents
Apr 19, 2024

No incidents reported today.

Apr 18, 2024

No incidents reported.

Apr 17, 2024
Resolved - This incident has been resolved.
Apr 17, 13:52 UTC
Identified - The issue has been identified and a fix is being implemented.
Apr 17, 12:44 UTC
Investigating - We are investigating potential availability issues with our Field Service Edge (FSE) services. You might experience latency on integration services in the production environment
We are actively investigating and will communicate with you as soon as it gets resolved.

We apologize for any inconvenience.

Apr 17, 12:17 UTC
Apr 16, 2024

No incidents reported.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024

No incidents reported.

Apr 9, 2024

No incidents reported.

Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024

No incidents reported.