ClickAccees (ClickSoftware Community)
Incident Report for Click
Resolved
This incident has been resolved.
ClickAccess, Click Community is back again.

-Click Support
Posted Feb 02, 2023 - 11:42 UTC
Investigating
Dear Click Customer,

We are experiencing issues with our Click Community.

We are currently investigating the issue. If you need urgently reach out to Click Support, Please call us on our support hotline.

We apologize for the inconvenience.


Thank you,

Click Support
Posted Feb 02, 2023 - 10:02 UTC
This incident affected: Click Customer Support (ClickAccess - Customer Community).